A Digital Help Logo Submit a Help Request

# What are the system requirements for Hosted Exchange?

Last updated: 15/08/18 at 20:28

Hosted Exchange is compatible with latest version of Office, Office 2010, Office 2007 (with slightly limited functionality), Office 2011 and 2013 for Mac.

Exchange will not work with Windows mail or older copies of Outlook Express.

Mac mail is also supported but will have more limited functionality.